Project flow by Moment - upgrade

Incident Report for Milient Software

Resolved

Upgrade has been completed.
Posted Jul 09, 2026 - 07:33 CEST

Identified

We are currently upgrading the application.
Posted Jul 09, 2026 - 07:00 CEST
This incident affected: Project Flow by Moment (Application).