Project Flow - Rapport3 integration connection failure

Incident Report for Milient Software

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 12:05 CEST

Update

We are continuing to monitor for any further issues.
Posted Apr 13, 2026 - 12:05 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 11:29 CEST

Identified

We are experienced a service interruption today due to an issue with our Microsoft Azure services. This affects our integration connections (powerBI). We are working to resolve the issue as soon as possible.
Posted Apr 10, 2026 - 14:41 CEST
This incident affected: Project Flow - Rapport (Cubic) (Project Flow - Rapport3).