Moment - Email sending

Incident Report for Milient Software

Postmortem

On 23 June 2026, between approximately 10:23 and 14:50 CEST, most customers were unable to receive emails from Moment.

What happened

A disruption in our email delivery affected the system's ability to send messages. Due to a weakness in how Moment handled that disruption, the problem was not contained as it should have been and instead interrupted email sending more broadly across the platform. The issue was specific to email delivery; no other Moment functionality was affected, and no customer data was lost.

Resolution and prevention

We restored normal email delivery by restarting core services. We are making email sending more resilient so disruptions are contained and improving our monitoring to detect similar issues quickly.

Posted Jun 24, 2026 - 13:08 CEST

Resolved

Emails are sending normally again. If you sent an invoice, offer, or other notification between 10:23 and 14:50 today, please resend it as those emails were not delivered. We are also working on correcting the status of invoices sent by email during this period. Contact support@milientsofware.com for more assistance.
Posted Jun 23, 2026 - 17:41 CEST

Monitoring

A fix has been implemented. We are monitoring the results and testing to ensure the issue has been resolved. We do not recommend sending important emails from the system until the incident has been resolved.
Posted Jun 23, 2026 - 15:05 CEST

Update

We are working on releasing a fix for the issue.
Posted Jun 23, 2026 - 14:45 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2026 - 14:17 CEST

Investigating

We are currently investigating reports of emails not being delivered.
Posted Jun 23, 2026 - 14:06 CEST
This incident affected: Project Flow by Moment (Application).